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The Ardour Digital Audio Workstation (DAW)
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Introduction - Who uses a DAW?
Musicians

Audio Engineers
Podcasters & Radio Producers
Soundtrack Editors
Composers & Singer/Songwriters
Multimedia Artists
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Introduction

/Me

is a musician, physicist and GNU/Linux user

contributes to Ardour and the wider linux-audio ecosystem since 2006
created a set of professional audio plugins
earned a PhD at Multimedia Digital Art Dept.
co-organized five Linux Audio Conferences
works full time on Ardour and Harrison Mixbus since 2017
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Introduction

What can you do with Ardour?
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Introduction
What can you do with Ardour?

Record / Import Audio/MIDI

Edit / Arrange
Mix / Master
Export

Remote Control
Customize / Hack / Misc.
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Introduction
What defines a DAW?

Unlimited multichannel tracks
Non destructive (media files once on disk never change)
Non linear editing
Automated real-time effects
...
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Overview

The average Ardour user only uses 10% of its capabilities.

Workflow dependent, every user requires a different subset of Ardour’s features.

Ardour accumulated various obscure features over the decades.
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Presentation Layout

Short Description
During presentation: Ardour Demo

Slides: Text description
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1

Lua Script
Buttons

Top right in Ardour’s toolbar are buttons that can be
assigned to custom scripted actions.
Right-click to assign a new script.
Scripts can be bound to keyboard shortcuts.
Preferences > Appearance > Toolbar
Edit > Lua Scripts > Script Manager
During the presentation this is used to skip to the next slide from
within Ardour.
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2

Hotplug MIDI
Devices

While the audio interface (which provides the clock) is fixed,
MIDI devices can be added or removed dynamically.

See also Preferences > MIDI which allows to set properties.
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3

Recorder View

Window > Recorder
Allows to directly monitor all physical inputs (incl. MIDI).
Rename Inputs
Create track(s) to record a given input
Monitor Inputs (if a monitor section is present)
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Recording
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4

Recording File
Format/Codec
e.g. FLAC

Directly record to e.g. FLAC
Reduce disk-space for long recordings
Useful for interviews, podcasts
Encode/decode of FLAC add a bit of CPU overhead
Session > Properties > File Format
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5

I/O Plugins

Use a Plugin to pre-process input (or output)
No mixer-strip required (outside of session context)
e.g “Expander/Gate”
Shown on the Recorder Page, like other physical inputs
Listed as ‘input-port’ in connection list
Window > I/O Plugins
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6

Wet Recording

Processor box context menu > Disk I/O
Customize signal flow in each mixer-strip
Pre: Input → Record → Play → ...
Post: ... → Record → Play → Output
Custom: allows to place plugins between Record and Play
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7

Record Modes

Layered - New regions are added on top
Non-Layered - Splice regions, replace existing audio
Sound-on-Sound - New audibly transparent regions are
added on top

Dropdown top-center in the toolbar
Track header context menu > Layers > Stacked
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8

Vari-speed
Recording

Set transport speed before recording VS transport control
Can lead to a nice chorus effect when doubling vocals or
guitars
Hint: only do subtle shifts, +/-1 semitone.
Preferences > Signal Flow > I/O Resampler (vari-speed)
quality
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9

Audition GM
MIDI Files

Session > Import
Audition MIDI files before dropping them into the session
Select a MIDI file, press play in the ‘Info box’
This play with default synth (General MIDI)
Note: make sure auditioner audio ports are connected
Window > Audio Connections
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10

Video Import
Trick

Open Video to
Import Audio

By default Ardour can only read files that Ardour can also
record to.

Session > Open Video
Extract Audio only

This can decode any file that ffmpeg can decode.
Some examples:

.xma2 - Xbox Media Audio 2

.aac - Apple/Advanced Audio Coding

.ac3 - Dolby Digital Audio Codec
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11

Import Samples
from Freesound Session > Import > Freesound
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The Editor
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12

Vari-speed
Playback

Set transport speed during playback
Optionally correct pitch using repitch plugin on
master-bus
https://x42-plugins.com/x42/x42-repitch
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13

Audition Range Select Range or regions, press a
Solos selected track(s) and plays range
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14

Edit Region Gain
with Range Tool

Press r to use range-tool
make a range-selection on an audio-region
Press d to select draw-tool
Drag region-gain (or automation) range. This
automatically adds guard-points
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15

Move Playhead to
transients

Split at transients

Select an Audio track and move to next/prev transient.
Ardour automatically locates just before the transient,
this way ‘split’ does not cut off the onset.
Transport > Playhead > Move to next transient
Ctrl + Right-Arrow, Ctrl + Left-Arrow
Preferences > Metering > Region Analysis
Ergonomic workflow using two keyboard shortcuts:
Ctrl + Right-Arrow, then s to split
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16

MIDI Step Entry right-click on MIDI Track record-arm
Create MIDI regions using step-entry GUI
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17

Live MIDI Step
Entry

right-click on MIDI Track record-arm
Use MIDI keyboard or virtual keyboard to write MIDI
Step by Step
Send MIDI data to track while in step-edit mode
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18

Poor Man’s MIDI
Sequencer

Enable Preferences > MIDI > Sound MIDI notes as they
are selected
Select a MIDI region, switch to e - ‘Internal-edit mode’
Press Tab to select next MIDI note in the region
Selection cycles at the end - “Poor man’s variable MIDI
step-looper”
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19

MIDI Transform

Mathematically transform MIDI data.
Region > MIDI > Transform...

Set [length] to [this note’s] [length] [ / ] [exactly] [2]
(halves note duration)

Set [Velocity] to [this note’s] [velocity] / [exactly] 20 *
[exactly] 20 + [exactly] 10
(map [0 - 20] to 10, [20 - 40] to 30 etc.)

Set [start time] to [this note’s] [start time]
* exactly 1000
+ a random number between 1 and 11
- a random number between 1 and 11
/ exactly 1000.
(micro timing, variation of less than 1/100th of a beat)
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20

MIDI Busses

Use a single synth for many MIDI busses
Create MIDI tracks without synth plugin

group tracks, right-click on group, add a subgroup bus
or manually create a MIDI bus, and connect the track’s
to its input

Add synth to MIDI bus
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The Mixer & Plugins
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21

Momentary

Middle-click for momentary action
Mute
Solo
Mixer Scene (!)
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22

Mixer Scenes
Use Mixer Scenes to save/recall all automatable mixer
parameters
Partially restore scene by selecting tracks
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23

Monitor Section
Add effects for monitoring only (not included in export)
Adjust solo-in-font dim level
Pre Fader Listen / After Fader listening path for use as
live mixer
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24

Mute Points

Ardour’s Mute control does not directly mute the signal in the
signal flow.
The signal is muted when it leaves the track:

main output
pre-fader sends
post-fader sends
listen (control out)
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25

VCA

Rather than groups to control volume, mute, solo
Nested VCA
Chained VCA

Adjust the drums with a Drum VCA, and also adjust the
percussion (including Drums) with the Percussion VCA
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26

Track Templates
Mixer Strip Header, context menu > Save as Template
Session > Add track or bus - pick template
Window > Template Manager
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Tag Plugins Tag and organize your favorite plugins
Benefit from 4830 existing tags
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28

DnD Plugins

reorder
copy settings
create preset

Drag & drop order of plugins, even post-fader
Drag & Drop a plugin onto another plugin of the same
type to copy its settings
Drag & drop a plugin to the sidebar to mark it as favorite
and create a preset
Drag from sidebar to track to load plugin (optionally with
preset)
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Pin Connections /
Sidechain

Use pin connections to connect sidechain plugin inputs
use pin-connections for separate stereo processing
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Plugin Analyser

Plugin: Edit with Generic Controls, Plugin Analysis
Analyze transfer function
Show phase
Plot live signal
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Plugin DSP Load

Window > Plugin DSP Load
Measure DSP load of individual Plugins
Shows proper statistics, incl. worst-case time to process
Allows to identify plugins that may cause dropouts
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32

Disable Plugin
Delay
Compensation

Preferences > Appearance > Toolbar > Latency
Compensation
Makes Ardour assume that all plugins have no latency
Direct signal is not delayed to align with latent
tracks/busses
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Show Automation
Line on Touch

Available for all touch-sensitive parameters
Works with plugin-GUIs, incl. third part Plugin UIs.
Edit > Show Automation Lane on Touch
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Lua Scripting
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34

Lua Scripting -
DSP plugins 1/4
Toys

Play Pong - add ACE
Use Automation to play Pong :)
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35

Lua Scripting -
DSP plugins 2/4
Utilities

“ACE-MIDI Monitor” - show MIDI data at any point in
the signal flow
“ACE Mute” - Mute anywhere in the signal chain via ACE
Mute plugin
“ACE 5.1 to Stereo” – decode 5.1 video surround sound
to stereo
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36

Lua Scripting -
DSP plugins 3/4
Control/Use
Ardour internals

Activate transport roll for remote recording by inserting
“Voice/Level Activate” plugin into the processor box and
enabling record mode.
“ACE Inline Scope”
“ACE Inline Spectrogram”
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37

Lua Scripting -
DSP plugins 4/4
Complex Plugins
using Ardour’s
Tempo Map

Arpeggiator - complex script with presets
Barlow & Raport Arp
https://github.com/Ardour/ardour/tree/master/
share/scripts
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38

Lua Scripting -
Session plugins
and Callbacks

Load Mixer scene when passing though a marker
Periodically Save Snapshot
Automatically snapshot on Export
Turn on tally light when recording
Rewind and play after loading session
etc.
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Lua Scripting -
Editor Actions

“Swing it”
Create Plugin Automation
Convert MIDI CC to Automation
Split regions at Markers
Collapse playlists
etc.
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Export
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40

Loudness Analyser

Preferences > Signal Flow > Master
“LAN” - Loudness Analysis and Normalization
Available on the master bus
Loudness targets Presets, only using gain
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Export Multiple
Files in One Go

Session > Export > Export to audio File
Take note the “Preset” dropdown at the top.
Streaming Preset
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Post Export
Analysis

Session > Export; Analyze Exported Audio
True peak values
LUFS short-term with a time graph, integrated loudness,
loudness range
Waveform and Spectrogram
Preferences > General > Save loudness analysis as image
after export
Preferences > General > Save mixer screenshot after
export
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43

File Access

Bounce to export

Audio/MIDI data is stored as files inside the session folder
SMF (standard MIDI file) .mid
Mono audio files (.wav, .flac)
Media files are directly accessible
Double-click on ‘Path’ in Menubar
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Miscellaneous
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44

Media Download
Window > Library Downloader
Editor Sidebar > Clips
Cue Sidebar > Clips
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Bounce to Trigger
Slot

Region Context menu > Bounce ..
Select Trigger Slot
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Session Snapshots
Session > Snapshot and keep working on current version
Session > Snapshot and switch to new version
Quickly switch between snapshots:
Editor Sidebar > Snapshots
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47

Connection
Matrix

Window > Audio Connections
Window > MIDI Connections
Connect multiple I/O by drawing a diagonal line
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Remote Control

Preferences > Control Surfaces
Control Ardour from your phone with Open Stage Control
Control Ardour from your phone with TouchOSC
Control Ardour from your phone using any Web browser
see Log Window; http://localhost:3818

Control Ardour from commandline
oscsend osc.udp://localhost:3819 /transport_start
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Rhythm Ferret

Region > Edit > Rhythm Ferret
Analyze region, places transient marker on region
Optionally move markers
Split
select all regions
Region > Position > Snap to Grid

64 / 67



50

Appearance
Change the overall appearance of the program to use
square buttons and/or a flat appearance
Choose between several different color themes.
LV2 Plugins are informed about theme and style
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What else can you do with Ardour?

Make a living?!
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Thank you for your attention!

Kudos to Paul Davis for creating Ardour
& to Harrison Consoles.
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